Kelsey Martens
Kelsey Martens

Director of Software Operations

Posted on Mar 20, 2015

Critical Update for Facebook Connect

Today we released Facebook Connect 3.0, which is a free, critical update for all customers using this add-on. The 1.x version of the Facebook API has been deprecated and will stop working after April 30, 2015. The latest version of Facebook Connect now uses the latest version of the Facebook Graph API (v2.2) and Javascript SDK. You need to act quickly and update to this version of Facebook Connect before April 30, 2015.

It's important to note that with this update comes a number of changes Facebook made that are out of our control. We strongly recommend that you thoroughly read over the change log for version 3.0, and the rest of the documentation. Some important changes to note are:

  • Updated Member_Data template tag to conform to new Facebook standards. There are a few variables and parameter names that have been updated or removed.
  • Updated Login and Set Permissions template tags to conform to new Facebook permission standards. Facebook now requires many permissions (including publish stream/actions) to be manually applied for and reviewed by Facebook.
  • Discontinued FB Registration plugin per Facebook (discontinued on their end). If you were using this, you'll need to use the Facebook Login approach instead.
  • Solspace Facebook Connect 3.x will only work on ExpressionEngine 2.6.x and up.

We also overhauled and updated the Demo templates that come along with the Facebook Connect add-on. They are prettier and more thorough in how they cover the variety of Facebook syncing options available, etc.

As always, if you have any questions, need any help with your upgrade, or run into any issues, just contact us for support and we'll be happy to assist you through this process! smile

Let's begin our conversation

Contact us now.